No announcement yet.

Making the Selected Menu Item Appear Selected

  • Filter
  • Time
  • Show
Clear All
new posts

  • Making the Selected Menu Item Appear Selected

    With the menu app, hovering over any item changes the colour so it's clear what you are about to click on. When you do click however, the menu item is indistinguishable from unselected items.

    I get by by using title of the running app (layout --> header) to display the currently running app. That's not really ideal though where the menu bar permanently shows in the browser. It is preferable to keep the hover color permanent after clicking until another button is clicked.

    If you have already solved this problem or have an idea of clear steps to do so, I would appreciate you share with me to save time experimenting. I'm not too strong with CSS.

  • #2
    Dear Scriptcaser
    go to your project root, search for folder _menuTheme
    then find your menu sheet document( the one your using for your project) for example:

    i use for my project Android /blue Horizontal
    then i have to edit the following files

    open files and replace the following
    ul#css3menu1 a:active, ul#css3menu1 a:focus{

    ul#css3menu1 a:active, ul#css3menu1 a:focus{
    background-color: #fff;}

    // for sure u can change the color according to you theme.

    i hope this will meet what you want.

    kindly note that i think you have to logout and login again in order changes to be effected

    best regards


    • #3
      Hello Walid, I've tried this but no difference. Coincidentally I'm using the same theme but LTR so I've modified just that CSS file under my app folder. Behavior is same as before:

      Before mouse-over: menu item is blue
      On mouse-over: menu item changes to white
      On click: menu item still white
      When mouse moves off: menu item reverts to blue (even though it has called the app).

      I've logged out, tried with 3 different browsers and cleared my cache also.


      • #4

        weird thing,

        i took a print screen for mine see attached, it is working!!

        try to edit both LTR, RTL file then clear cache and cookies, logout and close your browser . even restart your Pc. then test it.

        it should work fine