Announcement

Collapse
No announcement yet.

Question, RE: Updating PHP version for security

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question, RE: Updating PHP version for security

    I used the SC installer for Linux, which seems to have installed it's own version of Apache and PHP and they don't seem to be attached to any update repositories (they aren't attached to aptitude that's for sure).

    What is best practice method that NetMake / Scriptcase recommends we use to update PHP revision (i.e. I want to be sure that security patches and updates in my development environment are being applied)

    Right now my PHP version according to phpinfo() is reporting 5.4.30 with a build date of Sep 16 2014 ... but 5.4.41 is the current version with a build date of May 24 2015.

    It doesn't seem to me that SC is backporting PHP security updates when we update SC, so how can we safely update PHP without risking breaking our development environment??


  • #2
    If your sc instances will be exposed, and you are worried about security, do a manual install instead use installer ,and control your php instalation. Sc 8.1 will be compatble with php 5.5, 5.6
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      Originally posted by Giu View Post
      If your sc instances will be exposed, and you are worried about security, do a manual install instead use installer ,and control your php instalation. Sc 8.1 will be compatble with php 5.5, 5.6
      Maybe you missed the part where I said I used your Linux installer?? How would you recommend I apply updates and patches to the PHP installation using that method?

      I'm not looking to re-install my Scriptcase development environment, with all due respect that is not a solution. I'd prefer to just patch/update the one that works already which your installer setup. Seems like I should be able to do that without breaking PHP items (such as Zend Guard Loader).

      Thanks.

      Comment


      • #4
        Originally posted by CurtisB View Post
        Maybe you missed the part where I said I used your Linux installer?? How would you recommend I apply updates and patches to the PHP installation using that method?

        I'm not looking to re-install my Scriptcase development environment, with all due respect that is not a solution. I'd prefer to just patch/update the one that works already which your installer setup. Seems like I should be able to do that without breaking PHP items (such as Zend Guard Loader).

        Thanks.
        First, is not my installer, I don't work for Netmake.
        Second, you have automatic installer, and manual installer. I don't know if components on automatic installer are updated., or how to update it. I never worried because my SC instances are not exposed on internet. For this reason, I suggested to do a manual install, and control your configuration. You will not break anything to update from 5.4.x to 5.4.x+10
        /Giuseppe

        Professional Scriptcase Services
        Some Customers opinions

        Comment

        Working...
        X