Announcement

Collapse
No announcement yet.

Master/Detail

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Master/Detail

    Hi All,

    I am trying to link a form to a grid and all working fine except that when i run it, there is no buttons at the grid, it is not allowing to do anything. for example: add new or delete or update.

    i already check the toolbar and all buttons are there and when i run the grid alone all are there !!

    anyone know how to fix that ?


    thanks in advanced

    Best regards
    Walid Allaf

  • #2
    I think that you have set the security to 'on'? In that case you need to setup the security module and adjust the correct rights. Other option is to unset the security checkbox and regenerate it. If you are still in the development mode you can go to options -> myscriptcase and uncheck security resources.
    Albert Drent
    aducom software netherlands
    scriptcase partner, reseller, support and (turn-key) development
    www.scriptcase.eu / www.scriptcase.nl

    Comment


    • #3
      Originally posted by aducom View Post
      I think that you have set the security to 'on'? In that case you need to setup the security module and adjust the correct rights. Other option is to unset the security checkbox and regenerate it. If you are still in the development mode you can go to options -> myscriptcase and uncheck security resources.
      Thank you Mr. Albert for looking at this.

      security resources was unchecked also all the rights were given .
      i enabled security same thing, but when i checked the use of security , it is not working (i mean when i run the applications its run like the security resources unchecked !!!!

      back to the master / detail issue . i have another form and it is working as it should , i build this form with scriptcase v8.
      the other one where i can not get the toolbar i build it with scriptcase v 8.1

      if any one updated to v 8.1 check if he will have the same problem with master details to see if it is a bug or it is just with me ?

      Best Regards
      Walid Allaf

      Comment


      • #4
        When you link an application to another you select the buttons that should appear on the toolbar; try to check if you did not unselect all buttons on the application you are linking to.

        Comment


        • #5
          Is how grids works as detail. You have to use editabke grid form. When you use a grid as detail, you loose toolbar an pencil icon on grid, and have to manage it manually.

          Check this: http://www.scriptcase.net/forum/show...ht=grid+detail
          /Giuseppe

          Professional Scriptcase Services
          Some Customers opinions

          Comment


          • #6
            Originally posted by Giu View Post
            Is how grids works as detail. You have to use editabke grid form. When you use a grid as detail, you loose toolbar an pencil icon on grid, and have to manage it manually.

            Check this: http://www.scriptcase.net/forum/show...ht=grid+detail
            Thanks A lot, you saved my day


            Regards
            Walid

            Comment

            Working...
            X