Announcement

Collapse
No announcement yet.

Re-install problem sc8v1 on OSX El Capitan

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Re-install problem sc8v1 on OSX El Capitan

    Hello,

    I had to re-install my laptop with new OSX El Capitan and I requested for a new installation.My old Serial number was cancelled en received a new for my new installation.

    I installed sc8V1 but in the last step when the browser is going to "http://127.0.0.1:8081/scriptcase" to log in, I get always the message that there is no connection with the server.

    What could be wrong ?


    Thx,
    Geert

  • #2
    +1.

    I have the same problem.

    Originally posted by gesme View Post
    Hello,

    I had to re-install my laptop with new OSX El Capitan and I requested for a new installation.My old Serial number was cancelled en received a new for my new installation.

    I installed sc8V1 but in the last step when the browser is going to "http://127.0.0.1:8081/scriptcase" to log in, I get always the message that there is no connection with the server.

    What could be wrong ?


    Thx,
    Geert

    Comment


    • #3
      I've got the same issue. Seems like that the web server do not launch. I do not see any http server in the process list. How to start it manually?

      Comment


      • #4
        Resolved!
        The installation of scV81 uses XAMPP, for some reason in OSX El Capitan don't load the environment variable DYLD_LIBRARY_PATH.
        If you choose the default installation folder you have to edit /Applications/NetMake/v81/components/xamppfiles/bin/envvars file and replace the following lines to:
        #
        if test "x$DYLD_LIBRARY_PATH" != "x" ; then
        DYLD_LIBRARY_PATH="/Applications/NetMake/v81/components/xamppfiles/lib:$DYLD_LIBRARY_PATH"
        else
        DYLD_LIBRARY_PATH="/Applications/NetMake/v81/components/xamppfiles/lib"
        fi
        export DYLD_LIBRARY_PATH
        #

        Restart...

        and test: http://127.0.0.1:8081/scriptcase

        Comment


        • #5
          I see the exact lines you have in your post in my envvars but what do you change them to in order to fix this?

          Comment


          • #6
            mkio.

            Thank you so much for your post. I have been waiting for Scriptcase support to solve this for over a week! I finally able to resume work on my project.

            Peter

            Comment


            • #7
              Thanks Mkio,

              It works now.

              Another workaround is to disable SIP (System Integrity Protection) in OSX.

              1- start your Mac with CMD-R till you see the apple logo (recovery modus)
              2- start the terminal
              3- type the following command: csrutil disable
              4- restart your Mac


              (to enable again SIP type: csrutil enable

              Comment


              • #8
                You're welcome!

                The next Monday October 19 2015, ScriptCase will update ScriptCase V8.1 Installer for MacOS to fix installation problems on OS X El Capitan

                Comment


                • #9
                  Originally posted by mkio View Post
                  You're welcome!

                  The next Monday October 19 2015, ScriptCase will update ScriptCase V8.1 Installer for MacOS to fix installation problems on OS X El Capitan
                  Is the new installer release? I didn't see any notice from official website. The official website also didn't mention in the changelog. Please help.

                  Comment


                  • #10
                    what does i have really to change ? because i dont have recovery partition in my mac, what to change in my envars ?

                    Comment


                    • #11
                      Originally posted by mkio View Post
                      Resolved!
                      The installation of scV81 uses XAMPP, for some reason in OSX El Capitan don't load the environment variable DYLD_LIBRARY_PATH.
                      If you choose the default installation folder you have to edit /Applications/NetMake/v81/components/xamppfiles/bin/envvars file and replace the following lines to:
                      #
                      if test "x$DYLD_LIBRARY_PATH" != "x" ; then
                      DYLD_LIBRARY_PATH="/Applications/NetMake/v81/components/xamppfiles/lib:$DYLD_LIBRARY_PATH"
                      else
                      DYLD_LIBRARY_PATH="/Applications/NetMake/v81/components/xamppfiles/lib"
                      fi
                      export DYLD_LIBRARY_PATH
                      #

                      Restart...

                      and test: http://127.0.0.1:8081/scriptcase
                      Basically the path names are incomplete you don't need to reinstall anything.

                      Comment


                      • #12
                        any official comment or explanation from scriptcase? what's the exact way to resolve the issue? or we need to pay for the answer due to the bugs or misconfiguration of the software?

                        Comment

                        Working...
                        X