No announcement yet.

Install scriptcase v8.1 on linux system with Plesk v12.5

  • Filter
  • Time
  • Show
Clear All
new posts

  • Install scriptcase v8.1 on linux system with Plesk v12.5

    To have scriptcase v8.1 working fine in your Plesk 12.5 follow these steps:
    1. In your plesk panel under the domain that will contains the scriptcase installation, select PHP Settings and activate the PHP version 5.6.17, run PHP as FastCGI application served by Apache
    2. Download Zend Guard Loader from:
      select Linux and the Zend Guard Loader for PHP 5.6 64 bit
      Note: you must have a free account on Zend to download the file
    3. You get this file zend-loader-php5.6-linux-x86_64.tar.gz
      decompress it under your /tmp directory
      under /opt/plesk/php/5.6/lib64/php/modules make a copy of the file
      copy from /tmp/zend-loader-php5.6-linux-x86_64 the files:

      in /opt/plesk/php/5.6/lib64/php/modules
    4. Edit this file /opt/plesk/php/5.6/etc/php.d/00-ioncube-loader.ini
      add a line with:
    5. Restart your apache server:

      service httpd restart
    6. Done!
    7. Go to http://yourdomain/scriptcase and start the installation
    Good luck, I hope to have miss nothing ;-)
    Last edited by ranton; 02-07-2016, 12:58 PM.

  • #2
    Thanks for sharing

    Professional Scriptcase Services
    Some Customers opinions


    • #3
      Great Thanks

      Last edited by herveo; 07-05-2016, 06:36 AM.


      • #4
        Hi You all,
        I'm re installing a VPS under Cent OS 6.8 final and plesk 12.5.30 update 43 (latest on 2016/08/10) and PHP 5.6.24 fastCGI on Apache
        After many trials i'm no longer able to run zend guard loader as i had the habit and as Ranton describes the process

        1 - correct installation of Opcache and ZendGuardLoader in /opt/plesk/php/5.6/lib64/php/modules (both file permissions and owner checked)
        2- Modification of Ioncube loader ini file
        3 - httpd or even global server restart

        Zend guard not loading ....

        Have you encountered such problems with php 5.6.24 and/or new Plesk 12.5.30 #43 ? Thanks in advance


        • #5
          I have to apologize the problem was ... me !

          I shamefully share my mistake ..

          Switching from a PC to a Mac time depending on where I work, i have automaticly downloaded the MAC version for zendguardloader rather than the linux one !
          It only appears to me when i use the PHP-FPM ( to get more verbose indications : ELF header error my package was a darwin not a linux one ...