Announcement

Collapse
No announcement yet.

STUCKED !!!! New 8.1 has conflict with PHP 8.0x version

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • STUCKED !!!! New 8.1 has conflict with PHP 8.0x version

    Hello all,

    I did the download of zip file as manual installation and then I copied all files over previous scriptcase version.
    Now I got a error about PHP version

    This Scriptcase is encrypted for a different version of php, or your PHP don't have loaded Zend Guard Loader.
    Your PHP version is 5.4.29, please check the tutorial to learn how to update your php.
    Or download the version of Scriptcase appropriate for your environment.

    The link to http://www.scriptcase.net/php_56_upgrade .... obviously... don't work ;-(

    What have I to do ???

    I don't like to make another fresh installation of all SC from scratch

    Thanks so much..... I'm stucked here !!!

  • #2
    Originally posted by giovannino View Post
    Hello all,

    I did the download of zip file as manual installation and then I copied all files over previous scriptcase version.
    Now I got a error about PHP version

    This Scriptcase is encrypted for a different version of php, or your PHP don't have loaded Zend Guard Loader.
    Your PHP version is 5.4.29, please check the tutorial to learn how to update your php.
    Or download the version of Scriptcase appropriate for your environment.

    The link to http://www.scriptcase.net/php_56_upgrade .... obviously... don't work ;-(

    What have I to do ???

    I don't like to make another fresh installation of all SC from scratch

    Thanks so much..... I'm stucked here !!!
    You did some things bad. First maybe you downloaded the 5.6 version and tried to use in you 5.4 installation. You can't do thath.

    If you just want to upgrade from your 5.4, you just have to update like any other installation, is not needed more steps. If you just want try, do a manual installation, but in ANOTHER folder.

    I hope you did a backup
    http://www.scriptcase.net/forum/show...-to-upgrade-SC

    I did a new installation over a new apache with php5.6 and all is working as expected.Now SC apps and SC itself Is a lot of faster IMHO.
    /Giuseppe

    Professional Scriptcase Services
    Some Customers opinions

    Comment


    • #3
      OK Thanks !!!
      I did 5.4 installation over 5.6 and it works ;-) (luckly)..
      When I got time I will do a new enviroment with 5.6

      Comment


      • #4
        So what is required to get to 8.1 with support for PHP 5.6?

        Do I need to update my Ubuntu 14.04 to PHP 5.6, and then do a manual update of SC with the Linux flavour (with 5.6)?

        Comment


        • #5
          Originally posted by adz1111 View Post
          So what is required to get to 8.1 with support for PHP 5.6?

          Do I need to update my Ubuntu 14.04 to PHP 5.6, and then do a manual update of SC with the Linux flavour (with 5.6)?
          Or download automatic installer if you dont want a manual installation
          /Giuseppe

          Professional Scriptcase Services
          Some Customers opinions

          Comment


          • #6
            I did that originally Giu, but then I need to get a new serial number from NM as it was a "new" install. Which is a pain - especially if I decide it's too buggy and want to jump back to 8.0. If that does happen I would need to get a serial number yet again - sigh.

            Comment

            Working...
            X