Feedback

PostgreSQL with Scriptcase

In Scriptcase, we have four drivers to connecting with PostgreSQL. You must choose the most suitable for your environment. It is recommended to use PostgreSQL PDO which is more faster, however it is up to you to choose the driver. If you are using your own pre-configured environment, PostgreSQL extensions must be manually enabled in PHP.

You can check your enabled drivers by accessing your Scriptcase diagnosis. See below on how to locate your diagnosis and check if the driver is enabled.

  • Accessing the top menu Help > Diagnosis, you can easily find it through the interface.

Accessing diagnosis - Help Menu

  • Or, by accessing your browser url:

127.0.0.1:8092/scriptcase/diagnosis.php or domain.com/scriptcase/diagnosis.php

If the desired driver is already enabled and you just want to know how to connect with Scriptcase, click on the link below according to the driver that will be used.

Environment PostgreSQL PDO PostgreSQL 7 or Higher PostgreSQL 6.4 or Higher PostgreSQL 6.3 or Lower
Windows Connect Connect Connect Connect
Linux Connect Connect Connect Connect
macOS Connect Connect Connect Connect

Doubts or Connection Problems?

Contact our Support Team in case of connection problems or questions regarding this database.