Dear customer,
On October 21, 2026, two critical security vulnerabilities were disclosed in PHP, the language used by Scriptcase and by many web development platforms.
These vulnerabilities affect the PHP runtime environment and may compromise the security of servers running unpatched versions.
We recommend that all customers immediately check the PHP version used on their servers and apply the necessary security updates.
Scriptcase is currently compatible with PHP up to version 8.2. We therefore recommend updating to PHP 8.2.35 or a later release of the 8.2 series.
Customers using PHP 8.1 or earlier should also migrate to PHP 8.2.35 urgently. To help with this migration, we have prepared a page with guidance and free support: see how to move to PHP 8.2.
Please note that the identified vulnerabilities are in PHP itself and are not specific to Scriptcase.
We recommend keeping both your development environment and the servers used to publish applications up to date.
For more information, see the official PHP announcement:
https://www.php.net/archive/2026.php#2026-10-21-5
Best regards,
The Scriptcase Team
Start building applications using only your web browser with the most efficient web development environment. A powerful PHP generator for you to develop fast, simple, secure and with a low cost.
Try online with a cloud demo Download free trial for 20 days